Synchronizing the agenda with my smartphone (Android)

Good evening,

I created a CalDav account on my smartphone some weeks ago when I was planning to use the framasoft agenda. The synchronisation worked fine with the framagenda.
Since I have an agenda with as well now I wanted to synchronise this agenda instead of the framagenda. But the CalDav account keeps telling me that the server address is wrong.
I’m using the address given in the bottom left (
Am I using the wrong address?
The synchronisation of the contacts via a CardDav account worked fine (as with the contacts in framagenda).

Thanks a lot for your support

I guess you are using DavDroid.
Can you please:

  • uninstall it
  • reinstall the latest
  • install also the latest Nextcloud application
  • configure the cal from Nextcloud app?

Let me know if you need any help on this.

I’m not using DavDroid but CalDav. It works fine with the framagenda so I thought it would work as well for the agenda of indiehosters…
I’ll try with DavDroid.

Good evening,
DavDroid works perfectly well. I’m now all set.
Thanks a lot for the support…

It seems that I have a similar problem. I follow your instructions, I have a Davdroid account, but I don’t see new calendar on the Android Calendar app. Any idea of solution?

Sorry I cannot help. I stopped recently using Davdroid because each time a new version was released I had to fight too much to get things to continue working. After the last release, I didn’t manage to get the synchronisation working again and I gave up. Good luck!

Ouch… Thanks for your answer! And now how do you synchronise your calendar(s)?..

Ok I forgot some steps:

  1. in DAVdroid: select your account, and check the calendar(s)
  2. in DAVdroid: synchronise
  3. in Google Calendar: the account and the events appear
  4. if you have no new account in Google Calendar, check if you have an event in your indie cloud calendar, and if not, you have to create one (with the web interface)!
  5. it’s working! (for me)

I don’t synchronize any more… I unfortunately stopped using the agenda of Indie.Hosters… I’m back on gmail, for the agenda only… I’ll try to stay with Indie.hosters for the mails but I’ve started having issues accessing mails on my phone… My goal was to completely drop gmail but it is very difficult…

Really sorry to not be here more to help…

The thing is, there are so many configurations, that it is really difficult to follow… And test everything.

We updated our TLS (security) lately, but it seems it is creating more issues than solving…

@Isa what is the issue with the email?

Here is the diff for the technical persons:

+    ssl-default-bind-options no-sslv3 no-tlsv10 no-tlsv11 no-tls-tickets
+    ssl-default-server-options no-sslv3 no-tlsv10 no-tlsv11 no-tls-tickets

We are also now using let’s encrypt instead of startssl.

Hope it helps, and really hope the community can help us solve this.

I do have the same issue with agenda and contacts.

Is there a workaround I can do ?
How long should we hope it takes to get one or solve this issue ?
I’m using Android 4.1.2, the lastest on my old smartphone and hope it will not get me back to my google account…

(it doesn’t seems that the last Davdroid update (1.5.1-ose) from yesterday helps to solve.

I’m not sure yet: K9 reports issues when connecting the server, mainly when sending out emails. When it tries to retrieve mails, it has to try several times before it succeeds. The issues are quite recent I think.
But currently I don’t have internet access at home (huge issues impacting hundreds of persons which should be fixed end of May!). And I would like to be sure that the firewall rules at my work don’t have an impact. But as I cannot connect my phone at home, I have to wait to make some tests at home…

Good long weekend to everyone.

When did it started these issues?
(When you have those, it is always good to report immediately, then we
can know if it was related to a change we made recently.

Good morning,
I was not using the emails on the phone that often before so I’m not sure when it started. At the beginning of my internet outage at home, it was still working fine. I would say that the issues started in April.
And the type of error message I get is:
When sending email:
com.fsck.k9.mail.MessagingException:unable to open connection to SMTP server at
When reading email:
SocketTimeoutException: failed to connect to (port 993) after 30000ms
I’m using K9-mail 5.206 and my android version is 4.4.2.
I don’t know if it is an issue with the firewall rules at work, K9-mail or…

Could you try again? I rolled back the change we did beginning of April to increase security.


Yes! Much better! I was able to send and receive mails using k9-mail.
Thanks a lot.